WPBakery Page Builder had a security vulnerability that has been fixed in version 6.4.1. More information about this flaw in this article. We have updated all of our themes and included this version of the builder. Please update themes to the latest release and stay safe!

Okay
  Print

WP & Theme updates - Important!

When a major WP release arises it is crucial not to update WP version unless you are 100% sure that our Theme is compatible at that particular time. Proper order of update is Theme first, WP later

It is very important to stay always updated in both Theme & related plugins. Proper way of updating Theme & related plugins can be found here: How to update Engic.

You could frequently check the changelog of our Theme in the following link: Engic changelog.

In that way you can always be sure that your site will always work flawlessly.